Logging to email not working

Topics: Development Team Discussion, User Discussion
Nov 24, 2010 at 10:01 AM
Edited Nov 24, 2010 at 10:08 AM

Hi there,

I'm working on a project in which I'm using the Enterprise Library. The logging is configured in code by using the Fluent configuration API: link.
I can log using all the provided tracelisteners (FlatFile,Database, EventLog, etc.), except for the EmailTraceListener. After configuring this listener, nothing is happening when i want to log a message. 

 

I have also made a simple test project where i configure the EmailTraceListener  using the the Enterprise library configuration in Visual Studio (2010). But this seems to make no difference.
Does anyone know what could be going wrong? There are no exceptions thrown.

The only thing i can see what is possibly going wrong is in the output that Visual Studio creates: 'A first chance exception of type 'System.Net.Mail.SmtpException' occurred in System.dll'

This is the configuration i am using ( I've changed the email addresses and smtpServer)

 <add name="Email Trace Listener" 
		type="Microsoft.Practices.EnterpriseLibrary.Logging.TraceListeners.EmailTraceListener, 
Microsoft.Practices.EnterpriseLibrary.Logging, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
listenerDataType="Microsoft.Practices.EnterpriseLibrary.Logging.Configuration.EmailTraceListenerData, Microsoft.Practices.EnterpriseLibrary.Logging, Version=5.0.414.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
                toAddress="myEmail@address.com" fromAddress="myEmail@address.com"
                smtpServer="smptServerAddress"
                subjectLineStarter="Test begin" subjectLineEnder="Test End"
                smtpPort="25"
                formatter="Text Formatter" authenticationMode="WindowsCredentials"
                useSSL="true" />

 

One other question. Can i specify multiple email addresses and CC/BCC addresses?

I hope that you guys can help me out. I have searched the internet for a while, but until now i have not find a solution yet.

Many thanks,

Arie Bubberman

 

EDIT: This was probably not the right place for this discussion, so i have added the discussion to : http://entlib.codeplex.com/Thread/View.aspx?ThreadId=235841. This discussion can be closed/removed.