Enterprise library 3.1 compatability with SQLServer 2008?

Topics: Development Team Discussion, User Discussion
Sep 29, 2011 at 8:59 AM

 

Hi ,

Im currently using Enterprise Library 3.1 with .net 2.0 framework and Sqlserver 2005 as database.

I would like to upgrade my database server to 2008 ...

Is Enterprise library 3.1 compatible with SQL server 2008?

Please advice.

Thanks,

Niresh

Coordinator
Sep 29, 2011 at 7:50 PM
Hi Niresh,

I douth that Enterprise Library 3.1 was ever tested against MS SQL 2005 or 2008.

However, the Data Access Application Block can use pretty much any database provider specified by the user (Ex: System.Data.SqlClient, System.Data.OracleClient, etc.).

So I guess if you configure the block to use a provider compatible with MS SQL 2005/8, you should be able to make it work, even with v3.1.

Cheers,

Jeremi

From: [email removed]
To: [email removed]
Date: Thu, 29 Sep 2011 01:59:28 -0700
Subject: Enterprise library 3.1 compatability with SQLServer 2008? [entlibcontrib:274218]

From: NireshR

Hi ,
Im currently using Enterprise Library 3.1 with .net 2.0 framework and Sqlserver 2005 as database.
I would like to upgrade my database server to 2008 ...
Is Enterprise library 3.1 compatible with SQL server 2008?
Please advice.
Thanks,
Niresh
Read the full discussion online.
To add a post to this discussion, reply to this email (entlibcontrib@discussions.codeplex.com)
To start a new discussion for this project, email entlibcontrib@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com